Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2010-1130: PHP: Multiple vulnerabilities

Back to Search

Gentoo Linux: CVE-2010-1130: PHP: Multiple vulnerabilities

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:P/A:N)
Published
03/26/2010
Created
07/25/2018
Added
10/30/2017
Modified
10/30/2017

Description

session.c in the session extension in PHP before 5.2.13, and 5.3.1, does not properly interpret ; (semicolon) characters in the argument to the session_save_path function, which allows context-dependent attackers to bypass open_basedir and safe_mode restrictions via an argument that contains multiple ; characters in conjunction with a .. (dot dot).

Solution(s)

  • gentoo-linux-upgrade-dev-lang-php

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;