Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2010-3492: Python: Multiple vulnerabilities

Back to Search

Gentoo Linux: CVE-2010-3492: Python: Multiple vulnerabilities

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
10/19/2010
Created
07/25/2018
Added
10/30/2017
Modified
10/30/2017

Description

The asyncore module in Python before 3.2 does not properly handle unsuccessful calls to the accept function, and does not have accompanying documentation describing how daemon applications should handle unsuccessful calls to the accept function, which makes it easier for remote attackers to conduct denial of service attacks that terminate these applications via network connections.

Solution(s)

  • gentoo-linux-upgrade-dev-lang-python

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;