Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2010-3769: Mozilla Products: Multiple vulnerabilities

Back to Search

Gentoo Linux: CVE-2010-3769: Mozilla Products: Multiple vulnerabilities

Severity
9
CVSS
(AV:N/AC:M/Au:N/C:C/I:C/A:C)
Published
12/10/2010
Created
07/25/2018
Added
10/30/2017
Modified
04/05/2018

Description

The line-breaking implementation in Mozilla Firefox before 3.5.16 and 3.6.x before 3.6.13, Thunderbird before 3.0.11 and 3.1.x before 3.1.7, and SeaMonkey before 2.0.11 on Windows does not properly handle long strings, which allows remote attackers to execute arbitrary code via a crafted document.write call that triggers a buffer over-read.

Solution(s)

  • gentoo-linux-upgrade-dev-libs-nss
  • gentoo-linux-upgrade-mail-client-mozilla-thunderbird
  • gentoo-linux-upgrade-mail-client-mozilla-thunderbird-bin
  • gentoo-linux-upgrade-mail-client-thunderbird
  • gentoo-linux-upgrade-mail-client-thunderbird-bin
  • gentoo-linux-upgrade-net-libs-xulrunner
  • gentoo-linux-upgrade-net-libs-xulrunner-bin
  • gentoo-linux-upgrade-www-client-firefox
  • gentoo-linux-upgrade-www-client-firefox-bin
  • gentoo-linux-upgrade-www-client-icecat
  • gentoo-linux-upgrade-www-client-mozilla-firefox
  • gentoo-linux-upgrade-www-client-mozilla-firefox-bin
  • gentoo-linux-upgrade-www-client-seamonkey
  • gentoo-linux-upgrade-www-client-seamonkey-bin

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;