Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2010-3933: Ruby on Rails: Multiple vulnerabilities

Back to Search

Gentoo Linux: CVE-2010-3933: Ruby on Rails: Multiple vulnerabilities

Severity
6
CVSS
(AV:N/AC:L/Au:N/C:N/I:P/A:P)
Published
10/27/2010
Created
07/25/2018
Added
10/30/2017
Modified
10/30/2017

Description

Ruby on Rails 2.3.9 and 3.0.0 does not properly handle nested attributes, which allows remote attackers to modify arbitrary records by changing the names of parameters for form inputs.

Solution(s)

  • gentoo-linux-upgrade-dev-ruby-rails

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;