Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2010-4172: Apache Tomcat: Multiple vulnerabilities

Back to Search

Gentoo Linux: CVE-2010-4172: Apache Tomcat: Multiple vulnerabilities

Severity
4
CVSS
(AV:N/AC:M/Au:N/C:N/I:P/A:N)
Published
11/26/2010
Created
07/25/2018
Added
10/30/2017
Modified
10/30/2017

Description

Multiple cross-site scripting (XSS) vulnerabilities in the Manager application in Apache Tomcat 6.0.12 through 6.0.29 and 7.0.0 through 7.0.4 allow remote attackers to inject arbitrary web script or HTML via the (1) orderBy or (2) sort parameter to sessionsList.jsp, or unspecified input to (3) sessionDetail.jsp or (4) java/org/apache/catalina/manager/JspHelper.java, related to use of untrusted web applications.

Solution(s)

  • gentoo-linux-upgrade-www-servers-tomcat

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;