Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2011-4362: lighttpd: Multiple vulnerabilities

Back to Search

Gentoo Linux: CVE-2011-4362: lighttpd: Multiple vulnerabilities

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
12/24/2011
Created
07/25/2018
Added
10/30/2017
Modified
10/30/2017

Description

Integer signedness error in the base64_decode function in the HTTP authentication functionality (http_auth.c) in lighttpd 1.4 before 1.4.30 and 1.5 before SVN revision 2806 allows remote attackers to cause a denial of service (segmentation fault) via crafted base64 input that triggers an out-of-bounds read with a negative index.

Solution(s)

  • gentoo-linux-upgrade-www-servers-lighttpd

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;