Rapid7 VulnDB

Gentoo Linux: CVE-2013-1899: PostgreSQL: Multiple vulnerabilities

Back to Search

Gentoo Linux: CVE-2013-1899: PostgreSQL: Multiple vulnerabilities

Severity
7
CVSS
(AV:N/AC:L/Au:S/C:P/I:P/A:P)
Published
04/04/2013
Created
07/25/2018
Added
10/30/2017
Modified
10/30/2017

Description

Argument injection vulnerability in PostgreSQL 9.2.x before 9.2.4, 9.1.x before 9.1.9, and 9.0.x before 9.0.13 allows remote attackers to cause a denial of service (file corruption), and allows remote authenticated users to modify configuration settings and execute arbitrary code, via a connection request using a database name that begins with a "-" (hyphen).

Solution(s)

  • gentoo-linux-upgrade-dev-db-postgresql-server

References

  • gentoo-linux-upgrade-dev-db-postgresql-server

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;