Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2013-4852: PuTTY: Multiple Vulnerabilities

Back to Search

Gentoo Linux: CVE-2013-4852: PuTTY: Multiple Vulnerabilities

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
08/19/2013
Created
07/25/2018
Added
10/30/2017
Modified
06/15/2020

Description

Integer overflow in PuTTY 0.62 and earlier, WinSCP before 5.1.6, and other products that use PuTTY allows remote SSH servers to cause a denial of service (crash) and possibly execute arbitrary code in certain applications that use PuTTY via a negative size value in an RSA key signature during the SSH handshake, which triggers a heap-based buffer overflow.

Solution(s)

  • gentoo-linux-upgrade-net-ftp-filezilla
  • gentoo-linux-upgrade-net-misc-putty

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;