Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2013-6456: libvirt: Multiple vulnerabilities

Back to Search

Gentoo Linux: CVE-2013-6456: libvirt: Multiple vulnerabilities

Severity
6
CVSS
(AV:A/AC:M/Au:S/C:N/I:P/A:C)
Published
04/15/2014
Created
07/25/2018
Added
10/30/2017
Modified
10/30/2017

Description

The LXC driver (lxc/lxc_driver.c) in libvirt 1.0.1 through 1.2.1 allows local users to (1) delete arbitrary host devices via the virDomainDeviceDettach API and a symlink attack on /dev in the container; (2) create arbitrary nodes (mknod) via the virDomainDeviceAttach API and a symlink attack on /dev in the container; and cause a denial of service (shutdown or reboot host OS) via the (3) virDomainShutdown or (4) virDomainReboot API and a symlink attack on /dev/initctl in the container, related to "paths under /proc/$PID/root" and the virInitctlSetRunLevel function.

Solution(s)

  • gentoo-linux-upgrade-app-emulation-libvirt

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;