Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2014-2243: MediaWiki: Multiple vulnerabilities

Back to Search

Gentoo Linux: CVE-2014-2243: MediaWiki: Multiple vulnerabilities

Severity
6
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:N)
Published
03/01/2014
Created
07/25/2018
Added
10/30/2017
Modified
10/30/2017

Description

includes/User.php in MediaWiki before 1.19.12, 1.20.x and 1.21.x before 1.21.6, and 1.22.x before 1.22.3 terminates validation of a user token upon encountering the first incorrect character, which makes it easier for remote attackers to obtain access via a brute-force attack that relies on timing differences in responses to incorrect token guesses.

Solution(s)

  • gentoo-linux-upgrade-www-apps-mediawiki

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;