Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2014-3248: Facter: Privilege escalation

Back to Search

Gentoo Linux: CVE-2014-3248: Facter: Privilege escalation

Severity
6
CVSS
(AV:L/AC:H/Au:N/C:C/I:C/A:C)
Published
11/16/2014
Created
07/25/2018
Added
10/30/2017
Modified
10/30/2017

Description

Untrusted search path vulnerability in Puppet Enterprise 2.8 before 2.8.7, Puppet before 2.7.26 and 3.x before 3.6.2, Facter 1.6.x and 2.x before 2.0.2, Hiera before 1.3.4, and Mcollective before 2.5.2, when running with Ruby 1.9.1 or earlier, allows local users to gain privileges via a Trojan horse file in the current working directory, as demonstrated using (1) rubygems/defaults/operating_system.rb, (2) Win32API.rb, (3) Win32API.so, (4) safe_yaml.rb, (5) safe_yaml/deep.rb, or (6) safe_yaml/deep.so; or (7) operatingsystem.rb, (8) operatingsystem.so, (9) osfamily.rb, or (10) osfamily.so in puppet/confine.

Solution(s)

  • gentoo-linux-upgrade-dev-ruby-facter

References

  • gentoo-linux-upgrade-dev-ruby-facter

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;