Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2019-15947: Bitcoin: Multiple vulnerabilities

Free InsightVM Trial No credit card necessary
Watch Demo See how it all works
Back to Search

Gentoo Linux: CVE-2019-15947: Bitcoin: Multiple vulnerabilities

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:P/I:N/A:N)
Published
09/05/2019
Created
09/30/2020
Added
09/30/2020
Modified
09/30/2020

Description

In Bitcoin Core 0.18.0, bitcoin-qt stores wallet.dat data unencrypted in memory. Upon a crash, it may dump a core file. If a user were to mishandle a core file, an attacker can reconstruct the user's wallet.dat file, including their private keys, via a grep "6231 0500" command.

Solution(s)

  • gentoo-linux-upgrade-net-p2p-bitcoin-cli
  • gentoo-linux-upgrade-net-p2p-bitcoin-qt
  • gentoo-linux-upgrade-net-p2p-bitcoind

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;