Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2019-20800: Cherokee: Multiple vulnerabilities

Back to Search

Gentoo Linux: CVE-2019-20800: Cherokee: Multiple vulnerabilities

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
05/18/2020
Created
12/30/2020
Added
12/29/2020
Modified
12/29/2020

Description

In Cherokee through 1.2.104, remote attackers can trigger an out-of-bounds write in cherokee_handler_cgi_add_env_pair in handler_cgi.c by sending many request headers, as demonstrated by a GET request with many "Host: 127.0.0.1" headers.

Solution(s)

  • gentoo-linux-upgrade-www-servers-cherokee

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;