Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2020-14349: PostgreSQL: Multiple vulnerabilities

Back to Search

Gentoo Linux: CVE-2020-14349: PostgreSQL: Multiple vulnerabilities

Severity
5
CVSS
(AV:N/AC:H/Au:S/C:P/I:P/A:P)
Published
08/24/2020
Created
08/28/2020
Added
08/27/2020
Modified
09/04/2020

Description

It was found that PostgreSQL versions before 12.4, before 11.9 and before 10.14 did not properly sanitize the search_path during logical replication. An authenticated attacker could use this flaw in an attack similar to CVE-2018-1058, in order to execute arbitrary SQL command in the context of the user used for replication.

Solution(s)

  • gentoo-linux-upgrade-dev-db-postgresql

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;