Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2020-25695: PostgreSQL: Multiple vulnerabilities

Back to Search

Gentoo Linux: CVE-2020-25695: PostgreSQL: Multiple vulnerabilities

Severity
7
CVSS
(AV:N/AC:L/Au:S/C:P/I:P/A:P)
Published
11/16/2020
Created
12/08/2020
Added
12/07/2020
Modified
12/07/2020

Description

A flaw was found in PostgreSQL versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24. An attacker having permission to create non-temporary objects in at least one schema can execute arbitrary SQL functions under the identity of a superuser. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Solution(s)

  • gentoo-linux-upgrade-dev-db-postgresql

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;