Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2020-7471: Django: Multiple vulnerabilities

Back to Search

Gentoo Linux: CVE-2020-7471: Django: Multiple vulnerabilities

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
02/03/2020
Created
05/02/2020
Added
05/01/2020
Modified
05/01/2020

Description

Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection if untrusted data is used as a StringAgg delimiter (e.g., in Django applications that offer downloads of data as a series of rows with a user-specified column delimiter). By passing a suitably crafted delimiter to a contrib.postgres.aggregates.StringAgg instance, it was possible to break escaping and inject malicious SQL.

Solution(s)

  • gentoo-linux-upgrade-dev-python-django

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;