Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2020-8174: NodeJS: Multiple vulnerabilities

Back to Search

Gentoo Linux: CVE-2020-8174: NodeJS: Multiple vulnerabilities

Severity
9
CVSS
(AV:N/AC:M/Au:N/C:C/I:C/A:C)
Published
07/24/2020
Created
01/13/2021
Added
01/12/2021
Modified
01/12/2021

Description

napi_get_value_string_*() allows various kinds of memory corruption in node < 10.21.0, 12.18.0, and < 14.4.0.

Solution(s)

  • gentoo-linux-upgrade-net-libs-nodejs

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;