Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2021-3115: Go: Multiple Vulnerabilities

Back to Search

Gentoo Linux: CVE-2021-3115: Go: Multiple Vulnerabilities

Severity
5
CVSS
(AV:N/AC:H/Au:N/C:P/I:P/A:P)
Published
01/26/2021
Created
08/29/2022
Added
08/05/2022
Modified
08/05/2022

Description

Go before 1.14.14 and 1.15.x before 1.15.7 on Windows is vulnerable to Command Injection and remote code execution when using the "go get" command to fetch modules that make use of cgo (for example, cgo can execute a gcc program from an untrusted download).

Solution(s)

  • gentoo-linux-upgrade-dev-lang-go

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;