Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2021-32734: Nextcloud: Multiple Vulnerabilities

Back to Search

Gentoo Linux: CVE-2021-32734: Nextcloud: Multiple Vulnerabilities

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:P/I:N/A:N)
Published
07/12/2021
Created
08/29/2022
Added
08/11/2022
Modified
08/11/2022

Description

Nextcloud Server is a Nextcloud package that handles data storage. In versions prior to 19.0.13, 20.011, and 21.0.3, the Nextcloud Text application shipped with Nextcloud Server returned verbatim exception messages to the user. This could result in a full path disclosure on shared files. The issue was fixed in versions 19.0.13, 20.0.11, and 21.0.3. As a workaround, one may disable the Nextcloud Text application in Nextcloud Server app settings.

Solution(s)

  • gentoo-linux-upgrade-www-apps-nextcloud

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;