Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2022-22721: Apache HTTPD: Multiple Vulnerabilities

Back to Search

Gentoo Linux: CVE-2022-22721: Apache HTTPD: Multiple Vulnerabilities

Severity
6
CVSS
(AV:N/AC:M/Au:N/C:N/I:P/A:P)
Published
03/14/2022
Created
08/29/2022
Added
08/16/2022
Modified
09/01/2022

Description

If LimitXMLRequestBody is set to allow request bodies larger than 350MB (defaults to 1M) on 32 bit systems an integer overflow happens which later causes out of bounds writes. This issue affects Apache HTTP Server 2.4.52 and earlier.

Solution(s)

  • gentoo-linux-upgrade-app-admin-apache-tools
  • gentoo-linux-upgrade-www-servers-apache

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;