Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2022-25243: HashiCorp Vault: Multiple Vulnerabilities

Back to Search

Gentoo Linux: CVE-2022-25243: HashiCorp Vault: Multiple Vulnerabilities

Severity
4
CVSS
(AV:N/AC:M/Au:S/C:N/I:P/A:N)
Published
03/10/2022
Created
08/29/2022
Added
08/02/2022
Modified
08/02/2022

Description

"Vault and Vault Enterprise 1.8.0 through 1.8.8, and 1.9.3 allowed the PKI secrets engine under certain configurations to issue wildcard certificates to authorized users for a specified domain, even if the PKI role policy attribute allow_subdomains is set to false. Fixed in Vault Enterprise 1.8.9 and 1.9.4.

Solution(s)

  • gentoo-linux-upgrade-app-admin-vault

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;