Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2022-36042: Rizin: Multiple Vulnerabilities

Back to Search

Gentoo Linux: CVE-2022-36042: Rizin: Multiple Vulnerabilities

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
09/06/2022
Created
09/26/2022
Added
09/26/2022
Modified
09/26/2022

Description

Rizin is a UNIX-like reverse engineering framework and command-line toolset. Versions 0.4.0 and prior are vulnerable to an out-of-bounds write when getting data from dyld cache files. A user opening a malicious dyld cache file could be affected by this vulnerability, allowing an attacker to execute code on the user's machine. Commit number 556ca2f9eef01ec0f4a76d1fbacfcf3a87a44810 contains a patch.

Solution(s)

  • gentoo-linux-upgrade-dev-util-rizin

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;