Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2024-0450: Python, PyPy3: Multiple Vulnerabilities

Free InsightVM Trial No Credit Card Necessary
Watch Demo See how it all works
Back to Search

Gentoo Linux: CVE-2024-0450: Python, PyPy3: Multiple Vulnerabilities

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
03/19/2024
Created
05/06/2024
Added
05/06/2024
Modified
05/06/2024

Description

An issue was found in the CPython `zipfile` module affecting versions 3.12.1, 3.11.7, 3.10.13, 3.9.18, and 3.8.18 and prior. The zipfile module is vulnerable to “quoted-overlap” zip-bombs which exploit the zip format to create a zip-bomb with a high compression ratio. The fixed versions of CPython makes the zipfile module reject zip archives which overlap entries in the archive.

Solution(s)

  • gentoo-linux-upgrade-dev-lang-python
  • gentoo-linux-upgrade-dev-python-pypy3
  • gentoo-linux-upgrade-dev-python-pypy3_10
  • gentoo-linux-upgrade-dev-python-pypy3_9

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;