Rapid7 Vulnerability & Exploit Database

Jetty Command Execution Vulnerability

Back to Search

Jetty Command Execution Vulnerability

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:P/I:N/A:N)
Published
10/11/2002
Created
07/25/2018
Added
11/01/2004
Modified
12/04/2013

Description

Certain versions of Jetty do not correctly sanitize backslash characters in URL requests to the '/cgi-bin' directory. As a result, a remote attacker can execute arbitrary binaries anywhere the web server has access to.

Solution(s)

  • jetty-upgrade-4_1_1
  • jetty-upgrade-latest

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;