Rapid7 Vulnerability & Exploit Database

lighttpd: mod_auth not loaded by default (CVE-2007-3946)

Back to Search

lighttpd: mod_auth not loaded by default (CVE-2007-3946)

Severity
6
CVSS
(AV:N/AC:L/Au:N/C:P/I:N/A:P)
Published
07/23/2007
Created
07/25/2018
Added
12/08/2014
Modified
11/25/2016

Description

mod_auth (http_auth.c) in lighttpd before 1.4.16 allows remote attackers to cause a denial of service (daemon crash) via unspecified vectors involving (1) a memory leak, (2) use of md5-sess without a cnonce, (3) base64 encoded strings, and (4) trailing whitespace in the Auth-Digest header.

Solution(s)

  • http-lighttpd-upgrade-latest

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;