Rapid7 Vulnerability & Exploit Database

Huawei EulerOS: CVE-2019-3695: pcp security update

Back to Search

Huawei EulerOS: CVE-2019-3695: pcp security update

Severity
7
CVSS
(AV:L/AC:L/Au:N/C:C/I:C/A:C)
Published
03/03/2020
Created
02/23/2021
Added
02/22/2021
Modified
02/22/2021

Description

A Improper Control of Generation of Code vulnerability in the packaging of pcp of SUSE Linux Enterprise High Performance Computing 15-ESPOS, SUSE Linux Enterprise High Performance Computing 15-LTSS, SUSE Linux Enterprise Module for Development Tools 15, SUSE Linux Enterprise Module for Development Tools 15-SP1, SUSE Linux Enterprise Module for Open Buildservice Development Tools 15, SUSE Linux Enterprise Server 15-LTSS, SUSE Linux Enterprise Server for SAP 15, SUSE Linux Enterprise Software Development Kit 12-SP4, SUSE Linux Enterprise Software Development Kit 12-SP5; openSUSE Leap 15.1 allows the user pcp to run code as root by placing it into /var/log/pcp/configs.sh This issue affects: SUSE Linux Enterprise High Performance Computing 15-ESPOS pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise High Performance Computing 15-LTSS pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Module for Development Tools 15 pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Module for Development Tools 15-SP1 pcp versions prior to 4.3.1-3.5.3. SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Server 15-LTSS pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Server for SAP 15 pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Software Development Kit 12-SP4 pcp versions prior to 3.11.9-6.14.1. SUSE Linux Enterprise Software Development Kit 12-SP5 pcp versions prior to 3.11.9-6.14.1. openSUSE Leap 15.1 pcp versions prior to 4.3.1-lp151.2.3.1.

Solution(s)

  • huawei-euleros-2_0_sp2-upgrade-pcp
  • huawei-euleros-2_0_sp2-upgrade-pcp-compat
  • huawei-euleros-2_0_sp2-upgrade-pcp-conf
  • huawei-euleros-2_0_sp2-upgrade-pcp-doc
  • huawei-euleros-2_0_sp2-upgrade-pcp-export-pcp2graphite
  • huawei-euleros-2_0_sp2-upgrade-pcp-gui
  • huawei-euleros-2_0_sp2-upgrade-pcp-libs
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-activemq
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-apache
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-bash
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-bonding
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-cisco
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-dbping
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-dm
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-ds389
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-ds389log
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-elasticsearch
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-gfs2
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-gluster
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-gpfs
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-gpsd
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-json
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-kvm
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-lmsensors
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-logger
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-lustre
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-lustrecomm
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-mailq
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-memcache
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-mounts
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-mysql
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-named
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-netfilter
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-news
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-nfsclient
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-nginx
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-nvidia-gpu
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-pdns
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-postfix
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-postgresql
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-roomtemp
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-rpm
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-sendmail
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-shping
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-summary
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-trace
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-unbound
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-weblog
  • huawei-euleros-2_0_sp2-upgrade-pcp-pmda-zswap
  • huawei-euleros-2_0_sp2-upgrade-pcp-system-tools
  • huawei-euleros-2_0_sp2-upgrade-perl-pcp-pmda
  • huawei-euleros-2_0_sp2-upgrade-python-pcp

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;