Rapid7 Vulnerability & Exploit Database

Huawei EulerOS: CVE-2020-25715: pki-core security update

Back to Search

Huawei EulerOS: CVE-2020-25715: pki-core security update

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
04/30/2021
Created
04/30/2021
Added
04/30/2021
Modified
04/30/2021

Description

A flaw was found in pki-core. A specially crafted POST request can be used to reflect a DOM-based cross-site scripting (XSS) attack to inject code into the search query form which can get automatically executed. The highest threat from this vulnerability is to data integrity.

Solution(s)

  • huawei-euleros-2_0_sp3-upgrade-pki-base
  • huawei-euleros-2_0_sp3-upgrade-pki-base-java
  • huawei-euleros-2_0_sp3-upgrade-pki-ca
  • huawei-euleros-2_0_sp3-upgrade-pki-kra
  • huawei-euleros-2_0_sp3-upgrade-pki-server
  • huawei-euleros-2_0_sp3-upgrade-pki-symkey
  • huawei-euleros-2_0_sp3-upgrade-pki-tools

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;