Rapid7 Vulnerability & Exploit Database

Huawei EulerOS: CVE-2021-20277: samba security update

Back to Search

Huawei EulerOS: CVE-2021-20277: samba security update

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
04/30/2021
Created
04/30/2021
Added
04/30/2021
Modified
05/03/2021

Description

A flaw was found in Samba's libldb. Multiple, consecutive leading spaces in an LDAP attribute can lead to an out-of-bounds memory write, leading to a crash of the LDAP server process handling the request. The highest threat from this vulnerability is to system availability.

Solution(s)

  • huawei-euleros-2_0_sp3-upgrade-libsmbclient
  • huawei-euleros-2_0_sp3-upgrade-libwbclient
  • huawei-euleros-2_0_sp3-upgrade-samba
  • huawei-euleros-2_0_sp3-upgrade-samba-client
  • huawei-euleros-2_0_sp3-upgrade-samba-client-libs
  • huawei-euleros-2_0_sp3-upgrade-samba-common
  • huawei-euleros-2_0_sp3-upgrade-samba-common-libs
  • huawei-euleros-2_0_sp3-upgrade-samba-common-tools
  • huawei-euleros-2_0_sp3-upgrade-samba-libs
  • huawei-euleros-2_0_sp3-upgrade-samba-python
  • huawei-euleros-2_0_sp3-upgrade-samba-winbind
  • huawei-euleros-2_0_sp3-upgrade-samba-winbind-clients
  • huawei-euleros-2_0_sp3-upgrade-samba-winbind-modules

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;