Rapid7 Vulnerability & Exploit Database

Huawei EulerOS: CVE-2018-16866: systemd security update

Back to Search

Huawei EulerOS: CVE-2018-16866: systemd security update

Severity
2
CVSS
(AV:L/AC:L/Au:N/C:P/I:N/A:N)
Published
01/11/2019
Created
11/20/2019
Added
11/19/2019
Modified
02/28/2020

Description

An out of bounds read was discovered in systemd-journald in the way it parses log messages that terminate with a colon ':'. A local attacker can use this flaw to disclose process memory data. Versions from v221 to v239 are vulnerable.

Solution(s)

  • huawei-euleros-2_0_sp5-upgrade-libgudev1
  • huawei-euleros-2_0_sp5-upgrade-libgudev1-devel
  • huawei-euleros-2_0_sp5-upgrade-systemd
  • huawei-euleros-2_0_sp5-upgrade-systemd-devel
  • huawei-euleros-2_0_sp5-upgrade-systemd-libs
  • huawei-euleros-2_0_sp5-upgrade-systemd-python
  • huawei-euleros-2_0_sp5-upgrade-systemd-sysv
  • huawei-euleros-2_0_sp5-upgrade-systemd-udev-compat

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;