Rapid7 Vulnerability & Exploit Database

Huawei EulerOS: CVE-2019-1010023: glibc security update

Back to Search

Huawei EulerOS: CVE-2019-1010023: glibc security update

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
07/15/2019
Created
02/25/2020
Added
02/24/2020
Modified
11/18/2020

Description

** DISPUTED ** GNU Libc current is affected by: Re-mapping current loaded library with malicious ELF file. The impact is: In worst case attacker may evaluate privileges. The component is: libld. The attack vector is: Attacker sends 2 ELF files to victim and asks to run ldd on it. ldd execute code. NOTE: Upstream comments indicate "this is being treated as a non-security bug and no real threat."

Solution(s)

  • huawei-euleros-2_0_sp5-upgrade-glibc
  • huawei-euleros-2_0_sp5-upgrade-glibc-common
  • huawei-euleros-2_0_sp5-upgrade-glibc-devel
  • huawei-euleros-2_0_sp5-upgrade-glibc-headers
  • huawei-euleros-2_0_sp5-upgrade-glibc-static
  • huawei-euleros-2_0_sp5-upgrade-glibc-utils
  • huawei-euleros-2_0_sp5-upgrade-nscd

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;