Rapid7 Vulnerability & Exploit Database

Huawei EulerOS: CVE-2019-8921: bluez security update

Back to Search

Huawei EulerOS: CVE-2019-8921: bluez security update

Severity
3
CVSS
(AV:A/AC:L/Au:N/C:P/I:N/A:N)
Published
11/29/2021
Created
04/27/2022
Added
04/26/2022
Modified
04/26/2022

Description

An issue was discovered in bluetoothd in BlueZ through 5.48. The vulnerability lies in the handling of a SVC_ATTR_REQ by the SDP implementation. By crafting a malicious CSTATE, it is possible to trick the server into returning more bytes than the buffer actually holds, resulting in leaking arbitrary heap data. The root cause can be found in the function service_attr_req of sdpd-request.c. The server does not check whether the CSTATE data is the same in consecutive requests, and instead simply trusts that it is the same.

Solution(s)

  • huawei-euleros-2_0_sp5-upgrade-bluez
  • huawei-euleros-2_0_sp5-upgrade-bluez-libs
  • huawei-euleros-2_0_sp5-upgrade-bluez-libs-devel

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;