Rapid7 Vulnerability & Exploit Database

Huawei EulerOS: CVE-2020-14342: cifs-utils security update

Back to Search

Huawei EulerOS: CVE-2020-14342: cifs-utils security update

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
09/09/2020
Created
11/04/2020
Added
11/03/2020
Modified
11/03/2020

Description

It was found that cifs-utils' mount.cifs was invoking a shell when requesting the Samba password, which could be used to inject arbitrary commands. An attacker able to invoke mount.cifs with special permission, such as via sudo rules, could use this flaw to escalate their privileges.

Solution(s)

  • huawei-euleros-2_0_sp8-upgrade-cifs-utils
  • huawei-euleros-2_0_sp8-upgrade-pam_cifscreds

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;