Rapid7 Vulnerability & Exploit Database

IBM HTTP Server: CVE-2011-3192: Potential Denial of Service with malicious range requests

Back to Search

IBM HTTP Server: CVE-2011-3192: Potential Denial of Service with malicious range requests

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:C)
Published
08/29/2011
Created
07/25/2018
Added
06/22/2018
Modified
10/10/2018

Description

The byterange filter in the Apache HTTP Server 1.3.x, 2.0.x through 2.0.64, and 2.2.x through 2.2.19 allows remote attackers to cause a denial of service (memory and CPU consumption) via a Range header that expresses multiple overlapping ranges, as exploited in the wild in August 2011, a different vulnerability than CVE-2007-0086.

Solution(s)

  • ibm-http_server-apply-fix-pack-8_0_0_1
  • ibm-http_server-apply-interim-fix-pm46234-for-8_0

References

  • ibm-http_server-apply-fix-pack-8_0_0_1
  • ibm-http_server-apply-interim-fix-pm46234-for-8_0

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;