Rapid7 Vulnerability & Exploit Database

IBM WebSphere Application Server: CVE-2020-4589: WebSphere Application Server is vulnerable to a remote code execution vulnerability (CVE-2020-4589)

Free InsightVM Trial No Credit Card Necessary
Watch Demo See how it all works
Back to Search

IBM WebSphere Application Server: CVE-2020-4589: WebSphere Application Server is vulnerable to a remote code execution vulnerability (CVE-2020-4589)

Severity
10
CVSS
(AV:N/AC:L/Au:N/C:C/I:C/A:C)
Published
08/13/2020
Created
08/15/2020
Added
08/18/2020
Modified
08/24/2020

Description

IBM WebSphere Application Server 7.0, 8.0, 8.5, and 9.0 could allow a remote attacker to execute arbitrary code on the system with a specially-crafted sequence of serialized objects from untrusted sources. IBM X-Force ID: 184585.

Solution(s)

  • ibm-was-install-7-0-0-0-ph27414
  • ibm-was-install-8-0-0-0-ph27414
  • ibm-was-install-9-0-0-0-ph27414
  • ibm-was-upgrade-8-5-0-0-8-5-5-18
  • ibm-was-upgrade-9-0-0-0-9-0-5-5

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;