Rapid7 Vulnerability & Exploit Database

IBM WebSphere Application Server: CVE-2022-45787: IBM WebSphere Application Server Liberty is vulnerable to information disclosure due to Apache James MIME4J (CVE-2022-45787)

Free InsightVM Trial No Credit Card Necessary
Watch Demo See how it all works
Back to Search

IBM WebSphere Application Server: CVE-2022-45787: IBM WebSphere Application Server Liberty is vulnerable to information disclosure due to Apache James MIME4J (CVE-2022-45787)

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
01/06/2023
Created
03/13/2023
Added
03/13/2023
Modified
11/08/2023

Description

Unproper laxist permissions on the temporary files used by MIME4J TempFileStorageProvider may lead to information disclosure to other local users. This issue affects Apache James MIME4J version 0.8.8 and prior versions. We recommend users to upgrade to MIME4j version 0.8.9 or later.

Solution(s)

  • ibm-was-install-8-5-ph52079-liberty
  • ibm-was-upgrade-8-5-23-0-0-2-liberty

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;