Rapid7 Vulnerability & Exploit Database

IBM WebSphere Application Server: CVE-2023-28867: IBM WebSphere Application Server Liberty is vulnerable to a denial of service due to GraphQL Java (CVE-2023-28867)

Free InsightVM Trial No credit card necessary
Watch Demo See how it all works
Back to Search

IBM WebSphere Application Server: CVE-2023-28867: IBM WebSphere Application Server Liberty is vulnerable to a denial of service due to GraphQL Java (CVE-2023-28867)

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
03/27/2023
Created
06/01/2023
Added
06/01/2023
Modified
06/01/2023

Description

In GraphQL Java (aka graphql-java) before 20.1, an attacker can send a crafted GraphQL query that causes stack consumption. The fixed versions are 20.1, 19.4, 18.4, 17.5, and 0.0.0-2023-03-20T01-49-44-80e3135.

Solution(s)

  • ibm-was-install-8-5-ph54373-liberty
  • ibm-was-upgrade-8-5-23-0-0-6-liberty

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;