Rapid7 Vulnerability & Exploit Database

Jenkins Advisory 2022-09-21: CVE-2022-41224: XSS vulnerability

Back to Search

Jenkins Advisory 2022-09-21: CVE-2022-41224: XSS vulnerability

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
09/22/2022
Created
09/23/2022
Added
09/22/2022
Modified
09/26/2022

Description

Jenkins 2.367 through 2.369 (both inclusive) does not escape tooltips of the l:helpIcon UI component used for some help icons on the Jenkins web UI, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control tooltips for this component.

Solution(s)

  • jenkins-upgrade-2_370

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;