Back to search

JRE DER Decoding Denial of Service

Severity CVSS Published Added Modified
5 (AV:N/AC:L/Au:N/C:N/I:N/A:P) November 05, 2009 November 18, 2009 July 16, 2012

Available Exploits 

Description

Two vulnerabilities in the Java Runtime Environment (JRE) 6 update 16 and earlier, 5.0 update 21 and earlier, 1.4.2_23 and earlier as well as 1.3.1_26 and earlier are vulnerable to a denial of service involving decoding DER encoded data and parsing HTTP headers. This may allow a remote client to cause the JRE on the server to run out of memory, resulting in a DoS (Denial of Service) condition.

Free Nexpose Download

Discover, prioritize, and remediate security risks today!

 Download now

References

Solution

  • Oracle JRE >= 1.6.0.0 and < 1.6.0.17

    Upgrade to Oracle Java version 1.6.0.17

    Upgrade your copy of the Java Runtime Environment to 1.6.0.17, which can be downloaded from here.

  • Oracle JRE >= 1.5.0.0 and < 1.5.0.22

    Upgrade to Oracle Java version 1.5.0.22

    Upgrade your copy of the Java Runtime Environment to 1.5.0.22, which can be downloaded from here.

  • Oracle JRE >= 1.4.0.0 and < 1.4.2.24

    Upgrade to Oracle Java version 1.4.2.24

    Upgrade your copy of the Java Runtime Environment to 1.4.2.24, which can be downloaded from here. Note that this version requires Oracle Java SE Support, otherwise it is recommended to upgrade to the latest public JRE.

  • Oracle JRE >= 1.3.0.0 and < 1.3.1.27

    Upgrade to Oracle Java version 1.3.1.27

    Upgrade your copy of the Java Runtime Environment to 1.3.1.27, which can be downloaded from here.

Related Vulnerabilities