Rapid7 Vulnerability & Exploit Database

CESA-2002:129: php security update

Back to Search

CESA-2002:129: php security update

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
06/30/2001
Created
07/25/2018
Added
03/12/2010
Modified
07/04/2017

Description

PHP versions earlier than 4.1.0 contain a vulnerability that could allow arbitrary commands to be executed. [updated 22 Aug 2002] The initial set of errata packages contained an incorrect set of dependencies. This meant that a number of packages would need to be installed before php that were not essential to the operation of php. Updated errata packages are included with this advisory that have corrected dependencies.

PHP is an HTML-embedded scripting language commonly used with Apache. PHP versions 4.0.5 through 4.1.0 in safe mode do not properly cleanse the 5th parameter to the mail() function. This vulnerability allows local users and possibly remote attackers to execute arbitrary commands via shell metacharacters. CentOS Linux Advanced Server version 2.1 shipped with PHP 4.0.6. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CAN-2001-1246 to this issue. All users of PHP should upgrade to these errata packages containing PHP 4.1.2, which is not vulnerable to this issue. Note: This PHP errata enforces memory limits on the size of the PHP process to prevent a badly generated script from becoming a possible source for a denial of service attack. The default process size is 8Mb though you can adjust this as you deem necessary thought the php.ini directive memory_limit. For example, to change the process memory limit to 4MB, add the following: memory_limit 4194304 Important Installation Note: There are special instructions you should follow regarding your /etc/php.ini configuration file in the "Solution" section below.

Solution(s)

  • centos-upgrade-php
  • centos-upgrade-php-devel
  • centos-upgrade-php-imap
  • centos-upgrade-php-ldap
  • centos-upgrade-php-manual
  • centos-upgrade-php-mysql
  • centos-upgrade-php-odbc
  • centos-upgrade-php-pgsql

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;