Rapid7 Vulnerability & Exploit Database

CESA-2002:221: kdelibs security update

Back to Search

CESA-2002:221: kdelibs security update

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
11/29/2002
Created
07/25/2018
Added
03/12/2010
Modified
07/04/2017

Description

A number of vulnerabilities have been found that affect various versions of KDE. This errata provides updates for these issues.

KDE is a graphical desktop environment for workstations. A number of vulnerabilities have been found in various versions of KDE. The SSL capability for Konqueror in KDE 3.0.2 and earlier does not verify the Basic Constraints for an intermediate CA-signed certificate, which allows remote attackers to spoof the certificates of trusted sites via a man-in-the-middle attack. The Common Vulnerabilities and Exposures project has assigned the name CAN-2002-0970 to this issue. The cross-site scripting protection for Konqueror in KDE 2.2.2 and 3.0 through 3.0.3 does not properly initialize the domains on sub-frames and sub-iframes, which can allow remote attackers to execute scripts and steal cookies from subframes that are in other domains. (CAN-2002-1151) Multiple buffer overflows exist in the KDE LAN browsing implementation; the reslisa daemon contains a buffer overflow vulnerability which could be exploited if the reslisa binary is SUID root. Additionally, the lisa daemon contains a vulnerability which potentially enables any local user, as well any any remote attacker on the LAN who is able to gain control of the LISa port (7741 by default), to obtain root privileges. In CentOS Linux reslisa is not SUID root and lisa services are not automatically started. (CAN-2002-1247, CAN-2002-1306) CentOS Linux Advanced Server 2.1 provides KDE version 2.2.2 and is therefore vulnerable to these issues. This errata provides new kdelibs and kdenetworks packages which contain patches to correct these issues. Please note that there is are two additional vulnerabilities that affect KDE 2.x which are not fixed by this errata. A vulnerability in the rlogin KIO subsystem (rlogin.protocol) of KDE 2.x 2.1 and later, and KDE 3.x 3.0.4 and earlier, allows local and remote attackers to execute arbitrary code via a carefully crafted URL. (CAN-2002-1281). A similar vulnerability affects the telnet KIO subsystem (telnet.protocol) of KDE 2.x 2.1 and later. (CAN-2002-1282) At this time, CentOS recommends disabling both the rlogin and telnet KIO protocols as a workaround. To disable both protocols, execute these commands while logged in as root: rm /usr/share/services/rlogin.protocol rm /usr/share/services/telnet.protocol

Solution(s)

  • centos-upgrade-arts
  • centos-upgrade-kdelibs
  • centos-upgrade-kdelibs-devel
  • centos-upgrade-kdelibs-sound
  • centos-upgrade-kdelibs-sound-devel
  • centos-upgrade-kdenetwork
  • centos-upgrade-kdenetwork-ppp

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;