Updated W3M packages are available that fix two cross-site scripting issues.
W3M is a pager with Web browsing capabilities. Two cross-site scripting (XSS) issues have been found in W3M. An XSS vulnerability in W3M 0.3.2 allows remote attackers to insert arbitrary HTML and Web script into frames. Frames are disabled by default in the version of W3M shipped with CentOS Linux Advanced Server and Red Hat Linux Advanced Workstation. Therefore, this problem will not appear as long as users do not use W3M with the -F option, or enable frame support in either the /etc/w3m/w3mconfig or ~/.w3m/config configuration files. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CAN-2002-1335 to this issue. An XSS vulnerability in versions of W3M before 0.3.2.2 allows attackers to insert arbitrary HTML and Web script into image attributes. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CAN-2002-1348 to this issue. Users of W3M are advised to upgrade to the updated packages containing W3M 0.2.1 and a patch to correct these vulnerabilities.