Rapid7 Vulnerability & Exploit Database

ELSA-2011-1219 Moderate: Oracle Linux samba security update

Back to Search

ELSA-2011-1219 Moderate: Oracle Linux samba security update

Severity
10
CVSS
(AV:N/AC:L/Au:N/C:C/I:C/A:C)
Published
02/04/2010
Created
07/25/2018
Added
12/20/2011
Modified
04/11/2019

Description

Multiple integer overflows in vxsvc.exe in the Veritas Enterprise Administrator service in Symantec Veritas Storage Foundation 5.1 and earlier, Veritas Storage Foundation Cluster File System (SFCFS) 5.1 and earlier, Veritas Storage Foundation Cluster File System Enterprise for Oracle RAC (SFCFSORAC) 5.1 and earlier, Veritas Dynamic Multi-Pathing (DMP) 5.1, and NetBackup PureDisk 6.5.x through 6.6.1.x allow remote attackers to execute arbitrary code via (1) a crafted Unicode string, related to the vxveautil.value_binary_unpack function; (2) a crafted ASCII string, related to the vxveautil.value_binary_unpack function; or (3) a crafted value, related to the vxveautil.kv_binary_unpack function, leading to a buffer overflow.

Solution(s)

  • oracle-linux-upgrade-libsmbclient
  • oracle-linux-upgrade-libsmbclient-devel
  • oracle-linux-upgrade-samba
  • oracle-linux-upgrade-samba-client
  • oracle-linux-upgrade-samba-common
  • oracle-linux-upgrade-samba-swat

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;