Rapid7 Vulnerability & Exploit Database

ELSA-2013-0827 Important: Oracle Linux openswan security update

Back to Search

ELSA-2013-0827 Important: Oracle Linux openswan security update

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
05/15/2013
Created
07/25/2018
Added
05/15/2013
Modified
07/04/2017

Description

Buffer overflow in the atodn function in Openswan before 2.6.39, when Opportunistic Encryption is enabled and an RSA key is being used, allows remote attackers to cause a denial of service (pluto IKE daemon crash) and possibly execute arbitrary code via crafted DNS TXT records. NOTE: this might be the same vulnerability as CVE-2013-2052 and CVE-2013-2054.

Solution(s)

  • oracle-linux-upgrade-openswan
  • oracle-linux-upgrade-openswan-doc

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;