Rapid7 Vulnerability & Exploit Database

RHSA-2000:136: Updated PHP packages available for Red Hat Linux 5.2, 6.x, and 7

Back to Search

RHSA-2000:136: Updated PHP packages available for Red Hat Linux 5.2, 6.x, and 7

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:P/I:N/A:N)
Published
01/12/2001
Created
07/25/2018
Added
10/28/2005
Modified
07/04/2017

Description

Updated PHP packages are now available for Red Hat Linux 5.2, 6.x, and 7.

Clients uploading "multipart/form-data" information with form requests could cause PHP 3.0.17 to crash. The GD module was not compiled into the previously-issued PHP 4.0.3pl1 errata packages. The php-mysql package is linked against an older version of the libmysqlclient shared library, which was obsoleted by a previous MySQL errata. Security holes in versions 4.0.0 through 4.0.4 of the PHP Apache module have been found.

Solution(s)

  • redhat-upgrade-php
  • redhat-upgrade-php-imap
  • redhat-upgrade-php-ldap
  • redhat-upgrade-php-manual
  • redhat-upgrade-php-mysql
  • redhat-upgrade-php-pgsql

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;