Rapid7 Vulnerability & Exploit Database

RHSA-2001:094: Updated UW imap packages available (imap/pop3/imaps/pop3s)

Back to Search

RHSA-2001:094: Updated UW imap packages available (imap/pop3/imaps/pop3s)

Severity
5
CVSS
(AV:L/AC:L/Au:N/C:P/I:P/A:P)
Published
09/20/2001
Created
07/25/2018
Added
10/28/2005
Modified
07/04/2017

Description

The UW imap package contained various buffer overflow vulnerabilities which can lead to breach of security on a host running the imap and pop services from this package.

Several buffer overflow vulnerabilities have been found by both the authors of UW imap and others. The vulnerabilities are only exploitable after a user has authenticated with the server, giving a remote shell restricted to the permissions of the authenticated user. Impact: Systems that already allow users remote shell access are not affected by the buffer overflow vulnerabilities; however, it is highly recommended that all systems be upgraded to this release, as it fixes other server crabugs as well. In addition, imap server crashing problems related to messages containing null characters in the message body have been fixed in this release.

Solution(s)

  • redhat-upgrade-imap
  • redhat-upgrade-imap-devel

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;