Rapid7 Vulnerability & Exploit Database

RHSA-2001:115: New Zope packages are available

Back to Search

RHSA-2001:115: New Zope packages are available

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
10/10/2001
Created
07/25/2018
Added
03/24/2010
Modified
07/04/2017

Description

New Zope packages are available which fix a security flaw with DTML scripting.

The updated packages include a "hotfix" product which addresses a security problem with DTML scripting, as described in the Hotfix_2001-09-28 README.txt file: "The issue involves the fmt attribute of dtml-var tags. Without this correction, Zope does not check security access to methods invoked through fmt. This issue could allow partially trusted users with enough knowledge of Zope to call, in a limited way, methods they would not otherwise be allowed to access."

Solution(s)

  • redhat-upgrade-zope
  • redhat-upgrade-zope-components
  • redhat-upgrade-zope-core
  • redhat-upgrade-zope-pcgi
  • redhat-upgrade-zope-services
  • redhat-upgrade-zope-zpublisher
  • redhat-upgrade-zope-zserver
  • redhat-upgrade-zope-ztemplates

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;