Rapid7 Vulnerability & Exploit Database

RHSA-2001:147: remote exploit possible in lpd

Back to Search

RHSA-2001:147: remote exploit possible in lpd

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
10/03/2001
Created
07/25/2018
Added
10/28/2005
Modified
07/04/2017

Description

The lpd printing daemon provided by the lpr package posses a remotely exploitable hole.

The lpd printing daemon possess a flaw in the displayq code which makes a remote buffer overflow attack possible. [UPDATE November 7th, 2001] The initial package released as a fix for this problem itself had a segfault issue, and would crash when listing remote printers. The broken package, lpr-0.50.1-1, has been replaced with a working fix.

Solution(s)

  • redhat-upgrade-lpr

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;