Rapid7 Vulnerability & Exploit Database

RHSA-2002:063: Updated icecast packages are available

Back to Search

RHSA-2002:063: Updated icecast packages are available

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
04/22/2002
Created
07/25/2018
Added
03/24/2010
Modified
07/04/2017

Description

Updated icecast packages are available which fix a number of security issues.

Icecast is a mp3-based broadcasting system. Buffer overflows in Icecast 1.3.11 and earlier allow remote attackers to execute arbitrary code via a long HTTP GET request. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CAN-2002-0177 to this issue. Additional buffer overflow vulnerabilities exist in previous versions of Icecast that are also fixed by this update. These vulnerabilities can cause denial of service attacks as well as arbitrary code execution. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the names CAN-2001-0784, CAN-2001-1083, CAN-2001-1229, and CAN-2001-1230 to these issues. Users of Icecast are advised to update to the errata packages containing Icecast 1.3.12 which is not vulnerable to these issues.

Solution(s)

  • redhat-upgrade-icecast

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;