Rapid7 Vulnerability & Exploit Database

RHSA-2002:222: Updated apache, httpd, and mod_ssl packages available

Back to Search

RHSA-2002:222: Updated apache, httpd, and mod_ssl packages available

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
11/04/2002
Created
07/25/2018
Added
10/28/2005
Modified
07/04/2017

Description

Updated apache and httpd packages which fix a number of security issues are now available for Red Hat Linux 6.2, 7, 7.1, 7.2, 7.3, and 8.0.

The Apache HTTP Web Server is a secure, efficient, and extensible web server that provides HTTP services. Buffer overflows in the ApacheBench support program (ab.c) in Apache versions prior to 1.3.27, and Apache versions 2.x prior to 2.0.43, allow a malicious Web server to cause a denial of service (DoS) and possibly execute arbitrary code via a long response. The Common Vulnerabilities and Exposures project has assigned the name CAN-2002-0843 to this issue. Two cross-site scripting (XSS) vulnerabilities are present in the error pages for the default "404 Not Found" error and for the error response when a plain HTTP request is received on an SSL port. Both of these issues are only exploitable if the "UseCanonicalName" setting has been changed to "Off", and wildcard DNS is in use. These issues could allow remote attackers to execute scripts as other webpage visitors, for instance, to steal cookies. These issues affect versions of Apache 1.3 before 1.3.26, versions of Apache 2.0 before 2.0.43, and versions of mod_ssl before 2.8.12. (CAN-2002-0840, CAN-2002-1157) The shared memory scoreboard in the HTTP daemon for Apache 1.3, prior to version 1.3.27, allows a user running as the "apache" UID to send a SIGUSR1 signal to any process as root, resulting in a denial of service (process kill) or other such behavior that would not normally be allowed. (CAN-2002-0839). Note that this issue does not affect Red Hat Linux 8.0. All users of the Apache HTTP Web Server are advised to upgrade to the applicable errata packages. For Red Hat Linux 6.2, 7, 7.1, 7.2, and 7.3, these packages include Apache version 1.3.27 which is not vulnerable to these issues. For Red Hat Linux 8.0, the fixes have been back-ported and applied to Apache version 2.0.40. Note that the instructions in the "Solution" section of this errata contain additional steps required to complete the upgrade process.

Solution(s)

  • redhat-upgrade-apache
  • redhat-upgrade-apache-devel
  • redhat-upgrade-apache-manual
  • redhat-upgrade-httpd
  • redhat-upgrade-httpd-devel
  • redhat-upgrade-httpd-manual
  • redhat-upgrade-mod_ssl

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;