Updated PHP packages are available that fix a vulnerability in the wordwrap() function and a number of compatibility bugs.
PHP is an HTML-embedded scripting language commonly used with the Apache HTTP server. A heap-based buffer overflow was found in the wordwrap() function in PHP versions after 4.1.2 and before 4.3.0. If wordwrap() is used on user-supplied input this could allow remote attackers to cause a denial of service or execute arbitrary code. Red Hat Linux 8.0 shipped with a version of PHP that was vulnerable to this issue. Other Red Hat Linux distributions shipped with an earlier version of PHP and are not vulnerable to this issue. In addition, a number of compatiblity bugs have also been found between PHP 4.2 and Apache 2.0. All users of PHP are advised to upgrade to these erratum packages which contain a patch to correct these issues.