Rapid7 Vulnerability & Exploit Database

RHSA-2003:017: Updated PHP packages available

Back to Search

RHSA-2003:017: Updated PHP packages available

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
01/17/2003
Created
07/25/2018
Added
10/28/2005
Modified
07/04/2017

Description

Updated PHP packages are available that fix a vulnerability in the wordwrap() function and a number of compatibility bugs.

PHP is an HTML-embedded scripting language commonly used with the Apache HTTP server. A heap-based buffer overflow was found in the wordwrap() function in PHP versions after 4.1.2 and before 4.3.0. If wordwrap() is used on user-supplied input this could allow remote attackers to cause a denial of service or execute arbitrary code. Red Hat Linux 8.0 shipped with a version of PHP that was vulnerable to this issue. Other Red Hat Linux distributions shipped with an earlier version of PHP and are not vulnerable to this issue. In addition, a number of compatiblity bugs have also been found between PHP 4.2 and Apache 2.0. All users of PHP are advised to upgrade to these erratum packages which contain a patch to correct these issues.

Solution(s)

  • redhat-upgrade-php
  • redhat-upgrade-php-devel
  • redhat-upgrade-php-imap
  • redhat-upgrade-php-ldap
  • redhat-upgrade-php-manual
  • redhat-upgrade-php-mysql
  • redhat-upgrade-php-odbc
  • redhat-upgrade-php-pgsql
  • redhat-upgrade-php-snmp

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;